POWERHA Compatibility Matrix
HACMP Version Supported? AIX Level(s) MISC
1.2 NO 3.2.5
2.1 NO 3.2.5
3.1.0 NO 3.2.5
3.1.1 NO 3.2.5
4.1.0 NO 4.1.X
4.1.1 NO 4.1.X
4.2 NO 4.1.4, 4.2.X
4.2.1 NO 4.1.5, 4.2.X
4.2.2 NO 4.1.5, 4.2.1, 4.3.X
4.3 NO 4.3.2, 4.3.3
4.3.1 NO 4.3.2, 4.3.3
4.4 NO 4.3.3
4.4.1 NO 4.3.3, 5.1
4.5 NO 5.1, 5.2
5.1 NO 5.1, 5.2,5.3
5.2 NO 5.1, 5.2,5.3
5.3 NO 5.2(ML4), 5.3(ML2) or higher
6.1
AIX 5.2 RSCT 2.3.6 or higher
AIX 5.3 RSCT 2.4.2 or higher
5.4.0
5.4.1
NO 5.2 (TL8) or higher
5.3(TL4) or higher
AIX 5.2 RSCT 2.3.9 or higher
AIX 5.3 RSCT 2.4.5. or higher
5.4.1 NO –9/30/2011 6.1
7.1
5.5 No –4/30/2012 5.3 TL7
6.1 TL2,SP1
AIX 7.1
AIX 5.3 RSCT 2.4.10.0 or higher
AIX 6.1 RSCT 2.5.2.0 or higher
release_notes
6.1 (5765-H24) No – 04/2015 AIX 5.3 TL 9
AIX 6.1 TL2 SP1
AIX 7.1
AIX 5.3 RSCT 2.4.12.0 or higher
AIX 6.1 RSCT 2.5.4.0 or higher
release_notes
7.1
(5765-H39)
No –09/2014 AIX 6.1 TL6+
AIX 7.1
AIX 6.1 RSCT 3.1.0.0 or higher
AIX 7.1 RSCT 3.1.0.0
release_notes
7.1.1
(5765-H39)
No –04/2015 AIX 6.1 TL7 SP2
AIX 7.1 TL1 SP2
RSCT 3.1.2.0 or higher for both AIX versions
release_notes
7.1.2
(5765-H39)
No –6/2016 AIX 6.1 TL8 SP1
AIX 7.1 TL2 SP1
Hyperswap requires APAR IV27586
release_notes
7.1.3
(5765-H39)
Yes – 4/2018 AIX 6.1 TL9 SP1
AIX 7.1 TL3 SP1
release_notes
7.2.0
(5765-H39)
Yes AIX 6.1 TL9 SP5
AIX 7.1 TL3 SP5
AIX 7.1 TL4 SP1
AIX 7.2 SP1
release_notes
7.2.1
(5765-H39)
Yes AIX 7.1 TL3 SP7
AIX 7.1 TL4 SP2
AIX 7.2 SP2
AIX 7.2.1
Standard Edition
release_notesEnterprise Edition
release_notes
7.2.2
(5765-H39)
Yes AIX 7.1 TL4 SP4
AIX 7.1 TL5
AIX 7.2 SP4
AIX 7.2 TL1
AIX 7.2 TL2
Standard Edition
release_notes
Enterprise Edition
release_notes
7.2.3

(5765-H39)

Yes AIX 7.1 TL3 SP9
AIX 7.1 TL4 SP4
AIX 7.1 TL5
AIX 7.2 SP4
AIX 7.2 TL1 SP2
AIX 7.2 TL2
AIX 7.2 TL3
Standard Edition
release_notesEnterprise Edition
release_notes
7.2.4

(5765-H39)

Yes AIX 7.1 TL4 SP8
AIX 7.1 TL5 SP4
AIX 7.2 TL1 SP6
AIX 7.2 TL2 SP4
AIX 7.2 TL3 SP3
AIX 7.2 TL4 SP1
Standard Edition
release_notes

Enterprise Edition
release_notes

7.2.5

(5765-H39)

Yes AIX 7.1 TL5 SP6
AIX 7.2 TL2 SP5
AIX 7.2 TL3 SP4
AIX 7.2 TL4 SP2
AIX 7.2 TL5

Upgrade path options

6.1 7.1.1 7.1.2 7.1.3 7.2.0 7.2.1 7.2.2 7.2.3 7.2.4
5.5 R/S/O/N** Upgrade to PowerHA 6.1 SP15 first
6.1 NA Update to SP15 first then R/S/O is available
7.1.0 NA S/O S/O S/O Upgrade to 7.1.3 first then all options of R/S/O/N are available

 

7.1.1 NA NA R/S/O R/S/O
7.1.2 NA NA NA R/S/O R/S/O R/S/O R/S/O Upgrade to at least 7.2.0 first
7.1.3 NA NA NA NA R/S/O/N R/S/O/N* R/S/O/N* Upgrade to at least 7.2.0 first
7.2.0 NA NA NA NA NA R/S/O/N R/S/O/N* R/S/O/N*
7.2.1 NA NA NA NA NA NA R/S/O/N/Z** R/S/O/N/Z
7.2.2 NA NA NA NA NA NA NA R/S/O/N/Z
7.2.3 NA NA NA NA NA NA NA NA R/S/O/N/Z

R=Rolling Upgrade
S=Snapshot Upgrade
O=Offline Upgrade
N=Non-disruptive Upgrade

Z=cl_ezupdate – For upgrading to 7.2.3 make sure install images are from 6/2019, original sets from end of 2018 did not work.

*=NDU not officially supported beyond two version and assumes AIX levels are high enough to support the PowerHA version migrating to.

**=Requires SP1 as bare minimum starting point

AIX 4.3.3 AIX 5.1 AIX 5.1(64-bit) AIX 5.2 AIX 5.3 AIX 6.1 AIX 7.1 AIX 7.2
HACMP 4.5 No Yes No Yes No No No No
HACMP/ES 4.5 No Yes Yes Yes No No No No
HACMP/ES 5.1 No Yes Yes Yes Yes No No No
HACMP/ES 5.2 No Yes Yes Yes Yes No No No
HACMP/ES 5.3 No No No Yes Yes Yes No No
HACMP/ES 5.4.0 No No No TL8+ TL4+ No No No
HACMP/ES 5.4.1 No No No TL8+ TL4+ Yes Yes No
PowerHA 5.5 No No No No TL9+ TL2,SP1+ Yes No
PowerHA 6.1 No No No No TL9+ TL2,SP1+ Yes No
PowerHA 7.1 No No No No No TL6+ Yes No
PowerHA 7.1.1 No No No No No TL7+ TL1 SP2 SP1
PowerHA 7.1.2 No No No No No TL8 SP1 TL2 SP1 SP1
PowerHA 7.1.3 No No No No No TL9 SP1 TL3 SP1 SP1
PowerHA 7.2.0 No No No No No TL9 SP5 TL4 SP1 SP1
PowerHA  7.2.1 No No No No No No TL3 SP5

TL4 SP2

SP1

TL1

PowerHA 7.2.2 No No No No No No TL4 SP2

TL5

TL1

TL2

PowerHA 7.2.3 No No No No No No  

TL3 SP9
TL4 SP4
TL5

SP4
TL1 SP2
TL2
TL3
PowerHA 7.2.4 No No No No No No
TL4 SP8
TL5 SP4
TL5


TL1 SP6
TL2 SP4
TL3 SP3
TL4 SP1